upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-wsaccel / trunk / PKGBUILD
blobdb7cef72220b9ef6154076838c8c5058739c4b35
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-wsaccel
4 pkgver=0.6.4
5 pkgrel=2
6 pkgdesc='Accelerator for ws4py and AutobahnPython'
7 arch=('x86_64')
8 url='https://github.com/methane/wsaccel'
9 license=('Apache')
10 depends=('python')
11 makedepends=('python-setuptools' 'cython')
12 checkdepends=('python-pytest')
13 source=("https://github.com/methane/wsaccel/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('980364fab8a661c8a2b406f9eb6c99fb5f3a1308bbcf6267fa63f002d8dfbb4a3ad027d83a2088d69324cab05bdc56138d7e66e2602aeb8864dfe49ad9218d07')
16 build() {
17   cd wsaccel-$pkgver
18   python setup.py build
21 check() {
22   cd wsaccel-$pkgver
23   PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-311" pytest
26 package() {
27   cd wsaccel-$pkgver
28   python setup.py install --root="$pkgdir" -O1