upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-zipfile-deflate64 / repos / community-x86_64 / PKGBUILD
blobd9c799dd80cd434c7e39170c160ce50244043fda
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 pkgname=python-zipfile-deflate64
4 _pyname=${pkgname#python-}
5 pkgver=0.2.0
6 pkgrel=2
7 pkgdesc='Extract Deflate64 ZIP archives with Python’s zipfile API'
8 arch=(x86_64)
9 url="https://github.com/brianhelba/${_pyname}"
10 license=(Apache)
11 depends=(python)
12 makedepends=(python-{build,installer}
13              python-setuptools-scm
14              python-wheel)
15 # checkdepends=(python-pytest)
16 _archive="$_pyname-$pkgver"
17 # No tests in PyPi sources
18 source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
19 # No version information in archive
20 # source=("$url/archive/v$pkgver/$_archive.tar.gz")
21 sha256sums=('875a3299de102edf1c17f8cafcc528b1ca80b62dc4814b9cb56867ec59fbfd18')
23 build(){
24         cd "$_archive"
25         python -m build -wn
28 # check() {
29 #     cd "$_archive"
30 #     local _pyver=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
31 #     export PYTHONPATH="$PWD/build/lib.linux-$CARCH-$_pyver"
32 #     python -m pytest tests
33 # }
35 package() {
36         cd "$_archive"
37         python -m installer -d "$pkgdir" dist/*.whl