upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / python-zope-exceptions / trunk / PKGBUILD
blob7d2a7226839e3d321c2b52485d85ce73485f9f8c
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-zope-exceptions
4 pkgver=4.6
5 pkgrel=3
6 pkgdesc="Generic exceptions and implementations for Zope"
7 arch=('any')
8 url="https://github.com/zopefoundation/zope.exceptions"
9 license=('ZPL')
10 depends=('python-setuptools' 'python-zope-interface')
11 makedepends=('python-setuptools' 'python-zope-interface')
12 checkdepends=('python-zope-testrunner')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/zope.exceptions/archive/$pkgver.tar.gz")
14 sha512sums=('31bb34e3a28fc835b2265126250032591540f2f547f26e8c5fa5b295d6cec5111b1df53cb104df000f9ad4b9e6c2290e86c5bdd356903836068d5367a3e32977')
16 build() {
17   cd zope.exceptions-$pkgver
18   python setup.py build
21 check() {
22   cd zope.exceptions-$pkgver
23   PYTHONPATH="$PWD/build/lib" zope-testrunner --test-path=src
26 package() {
27   cd zope.exceptions-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1
31 # vim:set ts=2 sw=2 et: