1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Nathan Osman <nathan@quickmediasolutions.com>
7 pkgdesc='Simple and secure HTTP server for Qt'
9 url='https://github.com/nitroshare/qhttpengine'
12 makedepends=('cmake' 'ninja')
13 source=("https://github.com/nitroshare/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha256sums=('6505cf889909dc29bab4069116656e7ca5a9e879f04935139439c5691a76c55e')
17 cmake -S $pkgname-$pkgver -B build -G Ninja -DCMAKE_INSTALL_PREFIX='/usr' -DBUILD_TESTS=ON
22 ctest --test-dir build
26 DESTDIR="$pkgdir" cmake --install build
27 install -Dm644 $pkgname-$pkgver/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"