1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Ray Rashif <schiv@archlinux.org>
3 # Contributor: speps <speps at aur dot archlinux dot org>
4 # Contributor: Philipp Überbacher <hollunder at gmx dot at>
9 pkgdesc="Audio/MIDI multitrack sequencer"
11 url="https://qtractor.sourceforge.io/"
45 'new-session-manager: for session management'
46 'qt6-wayland: for native wayland support'
56 source=(https://github.com/rncbc/$pkgname/archive/refs/tags/${pkgname}_${pkgver//./_}.tar.gz)
57 sha512sums=('6314ae10020168f43b73c542e86bcb1ea5b088072930bfa4f2e8b89013e05a28af5de88ec7f41441d69b3bb3fbfb22868ed08a609089a48b630f3d482904d7b0')
58 b2sums=('0e7b8345557babd8accb74f3b97f5bcb4f089bf606703b048713870f9f9757276829bbd0287ec2d1353ed52d47271c99e3ce5e59aa70a84282114cc708441627')
63 -DCMAKE_BUILD_TYPE=None
64 -DCMAKE_INSTALL_PREFIX=/usr
66 -S $pkgname-${pkgname}_${pkgver//./_}
70 cmake "${cmake_options[@]}"
71 cmake --build build --verbose
81 libsamplerate libsamplerate.so
82 libsndfile libsndfile.so
83 libvorbis libvorbisenc.so libvorbisfile.so libvorbis.so
85 rubberband librubberband.so
88 DESTDIR="$pkgdir" cmake --install build
89 install -vDm 644 $pkgname-${pkgname}_${pkgver//./_}/{README,README.VST} -t "$pkgdir/usr/share/doc/$pkgname/"