1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: buckket <felix@buckket.org>
7 pkgdesc='An implementation of the redo build system in Python'
9 url='https://github.com/apenwarr/redo'
14 'python-beautifulsoup4'
17 optdepends=('python-setproctitle: pretty output')
19 conflicts=('redo-sh' 'redo-c' 'redo-jdebp')
20 _commit='7f00abc36be15f398fa3ecf9f4e5283509c34a00' # redo-0.42d
21 source=("$pkgname::git+$url.git#commit=$_commit")
27 git describe --tags | sed -e 's/^redo-//' -e 's/\([[:alpha:]]\)$/.\1/'
33 # tests fail with make 4.4+
36 # tests fail if C/CXX/LD FLAGS are set
37 # there's probably a cleaner way around this
38 local L_CFLAGS L_CXXFLAGS L_LDFLAGS
43 unset CFLAGS CXXFLAGS LDFLAGS
55 DESTDIR="$pkgdir" ./do install