1 # Maintainer: George Rawlinson <george@rawlinson.net.nz>
2 # Contributor: Max Mehl <aur at mehl dot mx>
3 # SPDX-FileCopyrightText: 2019 Max Mehl
4 # SPDX-License-Identifier: CC0-1.0
9 pkgdesc='Helper tool for providing and confirming copyright and licensing information'
11 url='https://reuse.software/'
12 license=('GPL3' 'Apache' 'custom:CC0-1.0')
16 'python-license-expression'
29 checkdepends=('python-pytest')
31 'git: git repository support'
32 'mercurial: mercurial repository support'
34 _commit='86f057b616d7f8c0a9d524c1c1a25e8ee3883101'
35 source=("$pkgname::git+https://github.com/fsfe/reuse-tool#commit=$_commit")
41 git describe --tags | sed 's/^v//'
47 python -m build --wheel --no-isolation
59 python -m installer --destdir="$pkgdir" dist/*.whl
62 install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" ./*.{rst,md}
65 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSES/*
67 sed -n '/## License/,$ p' README.md > "$pkgdir/usr/share/licenses/$pkgname/LICENSE"