upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / ruby-nenv / trunk / PKGBUILD
bloba2b01541f582e949db57cf5fdbb97c5e3010b3aa
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=ruby-nenv
4 pkgver=0.3.0
5 _commit=4d415f31d55deab8d338bdb343175959f855b2b0
6 pkgrel=2
7 pkgdesc="Convenient wrapper for Ruby's ENV"
8 arch=(any)
9 url='https://github.com/e2/nenv'
10 license=(MIT)
11 depends=(ruby)
12 makedepends=(git)
13 checkdepends=(ruby-rspec ruby-rake ruby-rubocop)
14 options=(!emptydirs)
15 source=(git+https://github.com/e2/nenv.git#commit=$_commit)
16 sha256sums=('SKIP')
18 prepare() {
19   cd nenv
20   sed -i '/[cC]overalls/d' spec/spec_helper.rb
22   # https://github.com/e2/nenv/issues/10
23   sed -i '/rubocop/d' Rakefile
26 build() {
27   local _gemdir="$(gem env gemdir)"
28   cd nenv
29   gem build nenv.gemspec
30   gem install \
31     --local \
32     --verbose \
33     --ignore-dependencies \
34     --no-user-install \
35     --install-dir "tmp_install/$_gemdir" \
36     --bindir "tmp_install/usr/bin" \
37     nenv-$pkgver.gem
38   find "tmp_install/$_gemdir/gems/" \
39     -type f \
40     \( \
41         -iname "*.o" -o \
42         -iname "*.c" -o \
43         -iname "*.so" -o \
44         -iname "*.time" -o \
45         -iname "gem.build_complete" -o \
46         -iname "Makefile" \
47     \) \
48     -delete
49   rm -r tmp_install/$_gemdir/cache
52 check() {
53   local _gemdir="$(gem env gemdir)"
54   cd nenv
55   GEM_HOME="tmp_install/$_gemdir" rake
58 package() {
59   cd nenv
60   cp -a tmp_install/* "$pkgdir"/
61   install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/