upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / scim-chewing / trunk / PKGBUILD
blob56ccf0e761908b5dafb18be839d8d52d70ace11d
1 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: whisky <archlinux.cle(at)gmail.com>
4 # Contributor: damir <damir@archlinux.org>
6 pkgname=scim-chewing
7 pkgver=0.5.1
8 pkgrel=2
9 pkgdesc='Traditional Chinese input method module for SCIM'
10 url='https://chewing.im/'
11 license=('GPL')
12 arch=('x86_64')
13 makedepends=('intltool')
14 depends=('scim' 'libchewing')
15 source=("$pkgname-$pkgver.tar.gz"::"https://github.com/chewing/scim-chewing/archive/v$pkgver.tar.gz")
16 sha256sums=('491b127784fa38734f3062fd57ea57e54f5f44d37b551ab25aab10c565cf6ebb')
18 prepare() {
19   cd ${pkgname}-${pkgver}
20   # ChangeLog is deprecated, but autotool expects one.
21   touch ChangeLog
22   autoreconf -vfi
23   intltoolize --force
26 build() {
27   cd ${pkgname}-${pkgver}
28   ./configure --prefix=/usr
29   make
32 package() {
33   cd ${pkgname}-${pkgver}
34   make DESTDIR="${pkgdir}" install