upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / soqt / trunk / PKGBUILD
blob7b6d1079372f10232b233b70249995dbdbe40349
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Gabriel Souza Franco
3 # Contributor: Florian Pritz
4 # Contributor: Christian Hesse <mail@eworm.de>
5 # Contributor: Thomas Dziedzic <gostrc@gmail.com>
6 # Contributor: Mickele
7 # Contributor: Marcus Fritzsch <fritschy@googlemail.com>
9 pkgname=soqt
10 pkgver=1.6.0
11 pkgrel=4
12 pkgdesc='The glue between Coin and Qt'
13 arch=(x86_64)
14 url='https://github.com/coin3d/soqt'
15 license=(GPL)
16 depends=(coin qt5-base)
17 makedepends=(cmake git mesa ninja doxygen)
18 # 75d4... is tag SoQt-1.6.0
19 # 3ff6... is tag soanydata-1_1_0
20 # a006... is tag soxt-1_4_0
21 source=("git+$url#commit=75d47669ae20f25ea4cd583c9298680254bdcff3"
22         "git+${url/soqt/soanydata}#commit=3ff6e9203fbb0cc08a2bdf209212b7ef4d78a1f2"
23         "git+${url/soqt/sogui}#commit=100612bf4016916dd686e2b6fecf8ac23d3db14d")
24 sha256sums=('SKIP'
25             'SKIP'
26             'SKIP')
28 prepare() {
29   # Set up links to the support repos
30   # (these are git submodules in what will be the next release)
31   ln -s "$srcdir/soanydata" soqt/data
32   ln -s "$srcdir/sogui" soqt/src/Inventor/Qt/common
34   # Skip cpack
35   mkdir -p soqt/cpack.d
36   touch soqt/cpack.d/CMakeLists.txt
39 build() {
40   mkdir -p build
41   cd build
42   cmake ../soqt \
43     -DCMAKE_C_FLAGS="$CFLAGS -fPIC -Wno-deprecated-declarations" \
44     -DCMAKE_CXX_FLAGS="$CXXFLAGS -fPIC -Wno-deprecated-declarations" \
45     -DCMAKE_INSTALL_PREFIX=/usr \
46     -DCMAKE_INSTALL_LIBDIR=lib \
47     -DSOQT_BUILD_DOC_MAN=ON \
48     -DSOQT_BUILD_DOC_CHM=OFF \
49     -G Ninja
50   ninja
53 package() {
54   DESTDIR="$pkgdir" ninja -C build install
56   # Skip the HTML documentation
57   rm -rf "$pkgdir/usr/share/doc"