upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / soundkonverter / trunk / PKGBUILD
blobdaa2118e3581959eb9e62496fc73746d629823c0
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
3 # Contributor: Mateusz Herych <heniekk@gmail.com>
4 # Contributor: Eric Belanger <eric@archlinux.org>
5 # Contributor: Darwin Bautista <djclue917@gmail.com>
7 pkgname=soundkonverter
8 pkgver=3.0.1
9 pkgrel=6
10 pkgdesc='Front-end to various audio converters'
11 arch=(x86_64)
12 url='https://www.linux-apps.com/content/show.php?content=29024'
13 license=(GPL)
14 depends=(hicolor-icon-theme kdelibs4support libkcddb cdparanoia taglib phonon-qt5)
15 makedepends=(extra-cmake-modules kdesignerplugin kdoctools kinit)
16 optdepends=('faac: faac backend'
17             'faad2: faad backend'
18             'ffmpeg: ffmpeg backend'
19             'flac: flac backend'
20             'fluidsynth: flouidsynth backend'
21             'lame: lame backend'
22             'mac: mac backend'
23             'mplayer: mplayer backend'
24             'opus-tools: opus backend'
25             'speex: speexenc, speexdec backends'
26             'timidity++: midi backend'
27             'twolame: twolame backend'
28             'vorbisgain: vorbisgain backend'
29             'vorbis-tools: vorbis tools backend'
30             'wavpack: wavpack backend'
31             'sox: sox plugin (change sample rate, various effects)')
32 source=(https://github.com/dfaust/soundkonverter/archive/v$pkgver/$pkgname-$pkgver.tar.gz
33         https://github.com/dfaust/soundkonverter/commit/3760bccb.patch)
34 sha256sums=('92117f8aff85aac3a336cc0c94f3739aaa2d07ddd741d737dfd4b1571c60a0ce'
35             '6dea893bd79d3848ba674e4735f4f5ec63b8d8b4d6a75c696e83f37876043633')
37 prepare() {
38   patch -d $pkgname-$pkgver -p1 < 3760bccb.patch # Fix taglib cmake module
41 build() {
42   cmake -B build -S $pkgname-$pkgver/src
43   cmake --build build
46 package() {
47   DESTDIR="$pkgdir" cmake --install build