upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / squeak-vm / trunk / PKGBUILD
blob48d5627be57e1fc007dc8a4ed7284846f16ccee8
1 # Maintainer: Jonathan Steel <jsteel at archlinux.org>
2 # Contributor: Piero Sartini <piero@sartini.de>
3 # Contributor: Cilyan Olowen <gaknar@gmail.com>
4 # Contributor: knut
5 # Contributor: kxmd
7 pkgname=squeak-vm
8 pkgver=4.10.2.2614
9 pkgrel=6
10 pkgdesc="Full-featured implementation of the Smalltalk programming language and environment"
11 arch=('x86_64')
12 url="http://squeakvm.org"
13 license=('custom:MIT' 'APACHE')
14 depends=('libgl' 'libpulse' 'libxrender')
15 makedepends=('cmake') 
16 source=(http://squeakvm.org/unix/release/Squeak-$pkgver-src.tar.gz)
17 md5sums=('8a5cb1d6899d55df56154fab8716e034')
18 sha256sums=('3db6d12ea223e5bc49f52af7f6f832e383a3a006a53bc8a87f6469e1af5dfc2e')
20 build() {
21   cd Squeak-$pkgver-src/
23   ./unix/cmake/configure --prefix=/usr --without-quartz --with-x \
24     --enable-mpg-mmx
26   make
29 package() {
30   cd Squeak-$pkgver-src  
32   make DESTDIR="$pkgdir" install
34   install -Dm644 "$srcdir"/Squeak-$pkgver-src/unix/doc/LICENSE \
35     "$pkgdir"/usr/share/licenses/$pkgname/LICENSE