upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / systemc / trunk / PKGBUILD
blob6a209ef6d38b180b9f874deebe78ced4d6acfa7e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Simon Doppler <dopsi[at]dopsi[dot]ch>
3 # Contributor: Kyle Brooks <brookskd[at]gmail[dot]com>
4 # Contributor: bl4ckb0x <navkamal90[at]gmail[dot]com>
6 pkgname=systemc
7 pkgver=2.3.4
8 pkgrel=1
9 pkgdesc="Set of C++ classes and macros which provide an event-driven simulation interface for modeling and describing complex hardware systems"
10 url="http://www.accellera.org/downloads/standards/systemc"
11 arch=('x86_64')
12 license=('Apache')
13 depends=('gcc-libs')
14 makedepends=('cmake' 'ninja')
15 replaces=('systemc-cmake')
16 source=("$pkgname-$pkgver.tar.gz::https://github.com/accellera-official/systemc/archive/$pkgver.tar.gz")
17 sha512sums=('3ef4b5e9c05b8d03e856598ddc27ad50a0a39a7f9334cd00faefeacdf954b6527104d3238c4e8bfa88c00dc382f4da5a50efbd845fe0b6cc2f5a025c993deefd')
19 prepare() {
20   mkdir -p build
21   sed -i 's/set (CMAKE_BUILD_TYPE Release/set (CMAKE_BUILD_TYPE ""/' $pkgname-$pkgver/CMakeLists.txt
24 build() {
25   cd build
26   cmake -GNinja -DCMAKE_CXX_STANDARD=17 -DCMAKE_INSTALL_PREFIX=/usr ../$pkgname-$pkgver
27   ninja
30 check() {
31   cd build
32   ninja check
35 package() {
36   cd build
37   DESTDIR="$pkgdir" ninja install