1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Simon Doppler <dopsi[at]dopsi[dot]ch>
3 # Contributor: Kyle Brooks <brookskd[at]gmail[dot]com>
4 # Contributor: bl4ckb0x <navkamal90[at]gmail[dot]com>
9 pkgdesc="Set of C++ classes and macros which provide an event-driven simulation interface for modeling and describing complex hardware systems"
10 url="http://www.accellera.org/downloads/standards/systemc"
14 makedepends=('cmake' 'ninja')
15 replaces=('systemc-cmake')
16 source=("$pkgname-$pkgver.tar.gz::https://github.com/accellera-official/systemc/archive/$pkgver.tar.gz")
17 sha512sums=('3ef4b5e9c05b8d03e856598ddc27ad50a0a39a7f9334cd00faefeacdf954b6527104d3238c4e8bfa88c00dc382f4da5a50efbd845fe0b6cc2f5a025c993deefd')
21 sed -i 's/set (CMAKE_BUILD_TYPE Release/set (CMAKE_BUILD_TYPE ""/' $pkgname-$pkgver/CMakeLists.txt
26 cmake -GNinja -DCMAKE_CXX_STANDARD=17 -DCMAKE_INSTALL_PREFIX=/usr ../$pkgname-$pkgver
37 DESTDIR="$pkgdir" ninja install