1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
3 # Contributor: Thomas Weißschuh <thomas t-8ch de>
4 # Contributor: James Reed <supplantr at archlinux dot info>
9 pkgdesc='Free and simple TrueCrypt implementation based on dm-crypt'
10 url='https://github.com/bwalex/tc-play'
13 depends=('glibc' 'device-mapper' 'util-linux-libs' 'libgcrypt' 'libuuid.so')
14 makedepends=('cmake' 'udev')
15 provides=('libtcplay.so')
16 source=(https://github.com/bwalex/tc-play/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
17 sha256sums=('ad53cd814a23b4f61a1b2b6dc2539624ffb550504c400c45cbd8cd1da4c7d90a')
18 b2sums=('c02489d6e291dfc1425745af86506e72fda7f67dba0668b9250a85604ba301761b5bbbad6927238042a0f89da1035d9e3275006e34e895835a53cdc24974f419')
21 mkdir -p tc-play-${pkgver}/build
22 cd tc-play-${pkgver}/build
24 export CFLAGS+=" ${CPPFLAGS}"
26 -DCMAKE_INSTALL_PREFIX=/usr \
34 make -C build DESTDIR="$pkgdir" install
35 install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
36 install -Dm 644 CHANGELOG README.md -t "${pkgdir}/usr/share/doc/${pkgname}"