1 # Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
2 # Maintainer: Morten Linderud <foxboron@archlinux.org>
7 pkgdesc='Unprivileged development environment'
9 url='https://github.com/containers/toolbox'
11 depends=(podman bash flatpak)
12 makedepends=(go shellcheck go-md2man bash-completion ninja git meson podman)
13 _commit=f7c4c7dedb34be33333065296275869e77464400 #refs/tags/0.0.99.4^{}
14 source=("git+$url#commit=$_commit")
19 git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
24 # Fixes https://github.com/containers/toolbox/issues/1246
25 git cherry-pick -n 816a7cab9e2f02f2eb828062be54ffef2e3666dc
26 git cherry-pick -n f555029304415a06bde410deb879cd2cc7dad444
27 git cherry-pick -n fc5f568c5d82f4a16982268fa67092e52be91fbe
32 export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
33 export CGO_LDFLAGS="${LDFLAGS}"
34 export CGO_CFLAGS="${CFLAGS}"
35 export CGO_CPPFLAGS="${CPPFLAGS}"
36 export CGO_CXXFLAGS="${CXXFLAGS}"
37 arch-meson toolbox build -D profile_dir=/etc/profile.d
42 DESTDIR="$pkgdir" ninja -C build install