upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / toolbox / repos / community-x86_64 / PKGBUILD
blob666711394f10e4421957b4af115383501e934697
1 # Maintainer: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
2 # Maintainer: Morten Linderud <foxboron@archlinux.org>
4 pkgname=toolbox
5 pkgver=0.0.99.4
6 pkgrel=1
7 pkgdesc='Unprivileged development environment'
8 arch=(x86_64)
9 url='https://github.com/containers/toolbox'
10 license=(APACHE)
11 depends=(podman bash flatpak)
12 makedepends=(go shellcheck go-md2man bash-completion ninja git meson podman)
13 _commit=f7c4c7dedb34be33333065296275869e77464400        #refs/tags/0.0.99.4^{}
14 source=("git+$url#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd toolbox
19   git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
22 prepare() {
23   cd toolbox
24   # Fixes https://github.com/containers/toolbox/issues/1246
25   git cherry-pick -n 816a7cab9e2f02f2eb828062be54ffef2e3666dc
26   git cherry-pick -n f555029304415a06bde410deb879cd2cc7dad444
27   git cherry-pick -n fc5f568c5d82f4a16982268fa67092e52be91fbe
28     
31 build() {
32   export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
33   export CGO_LDFLAGS="${LDFLAGS}"
34   export CGO_CFLAGS="${CFLAGS}"
35   export CGO_CPPFLAGS="${CPPFLAGS}"
36   export CGO_CXXFLAGS="${CXXFLAGS}"
37   arch-meson toolbox build -D profile_dir=/etc/profile.d
38   ninja -C build
41 package() {
42   DESTDIR="$pkgdir" ninja -C build install