upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / unhide / trunk / PKGBUILD
blob13ef2a79263b7f82a49a92eede1ed1f2c9d6c36c
1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
3 pkgname=unhide
4 pkgver=20220611
5 pkgrel=2
6 pkgdesc='A forensic tool to find processes hidden by rootkits, LKMs or by other techniques.'
7 arch=('x86_64')
8 url='https://github.com/YJesus/Unhide/'
9 license=('GPL3')
10 depends=('iproute2' 'lsof' 'psmisc' 'net-tools' 'procps-ng')
11 source=("https://github.com/YJesus/Unhide/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
12         "Makefile")
13 md5sums=('cb0fc465ef26e907ba2166551dc27369'
14          '68ec8dcd2f25d4d5dad089a8535d462f')
15 sha256sums=('db0c29b6519982df07a9024d37b1e4618d40eaf13c2c01737ec79dcfba108eb6'
16             '6d2a37133a5cb05995bf0c8f8230820ce24b6f3369c49e84a6da7684d2bb6579')
18 prepare() {
19   cp -f Makefile Unhide-$pkgver/
22 build() {
23   cd Unhide-$pkgver
24   make
27 package() {
28   cd Unhide-$pkgver
29   make PREFIX=/usr DESTDIR="$pkgdir" install
30   ln -s unhide-linux "$pkgdir/usr/bin/unhide"