1 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinuc.org>
2 # Contributor: Johannes Pohl <johannes.pohl90@gmail.com>
7 pkgdesc='Universal Radio Hacker: investigate wireless protocols like a boss'
9 url='https://github.com/jopohl/urh'
11 depends=('python' 'python-pyqt5' 'python-numpy' 'python-psutil' 'cython')
12 makedepends=('gcc' 'python-setuptools' 'airspy' 'hackrf' 'libuhd' 'limesuite' 'rtl-sdr' 'bladerf' 'libiio')
13 checkdepends=('python-pytest-runner' 'python-pytest-xdist' 'xorg-server-xvfb')
14 optdepends=('airspy: Airspy backend'
15 'cython: compiling native modules inside URH'
16 'hackrf: HackRF backend'
17 'libuhd: USRP backend'
18 'limesuite: LimeSDR backend'
19 'rtl-sdr: RTL-SDR backend'
20 'gnuradio: GNURadio backend'
21 'bladerf: BladeRF backend'
22 'python-pylibiio: IIO backend (PlutoSDR)'
23 'gnuradio-osmosdr: OsmoSDR backend, via GNURadio'
24 'python-pyaudio: Soundcard backend')
25 source=("$pkgname-$pkgver.tar.gz::https://github.com/jopohl/urh/archive/v$pkgver.tar.gz")
26 sha512sums=('a888c20a4d2f349960e41defdb5cce6590d4523f8a1a655e21e4caaf7dd98a6f51936fa5a038787cb5935bc42e8863d2940059130dc9982caeea4b80e431aeeb')
31 python setup.py build build_ext
32 python src/urh/cythonext/build.py
44 python setup.py install --root="$pkgdir" -O1 --skip-build
46 install -Dm644 ./data/urh.desktop "$pkgdir"/usr/share/applications/urh.desktop
47 install -Dm 644 data/icons/appicon.png "$pkgdir"/usr/share/pixmaps/urh.png
48 install -Dm 644 README.md "$pkgdir"/usr/share/doc/$pkgname/README