1 # Maintainer: Filipe Laíns (ffy00) <lains@archlinux.org>
2 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 # Maintainer: Orhun Parmaksız <orhun@archlinux.org>
6 pkgname=uutils-$_pkgname
9 pkgdesc='Cross-platform Rust rewrite of the GNU coreutils'
11 url='https://github.com/uutils/coreutils'
13 depends=('glibc' 'gcc-libs')
14 makedepends=('rust' 'cargo' 'python-sphinx')
15 source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
16 sha512sums=('307f84ab58694f8216890a1755867d4b863a3722c593f7bdb6af2d6186f3464b3ed62c59a4a7dd703a8ff659a4d95c11a532b4f1fa8f107b8671394920bfa279')
21 sed 's|"bin"|"builduser"|g' -i tests/by-util/test_{chgrp,chown}.rs
35 CARGOFLAGS=--release \
36 TEST_NO_FAIL_FAST="--no-fail-fast -- \
37 --skip test_chown::test_big_p \
38 --skip test_chgrp::test_big_p \
39 --skip test_chgrp::test_big_h"
48 MANDIR=/share/man/man1 \
53 install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE