upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / uutils-coreutils / trunk / PKGBUILD
blob65615e0a45ef1feafbb7cbecd1fb50fc34b71dd1
1 # Maintainer: Filipe Laíns (ffy00) <lains@archlinux.org>
2 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 # Maintainer: Orhun Parmaksız <orhun@archlinux.org>
5 _pkgname=coreutils
6 pkgname=uutils-$_pkgname
7 pkgver=0.0.18
8 pkgrel=1
9 pkgdesc='Cross-platform Rust rewrite of the GNU coreutils'
10 arch=('x86_64')
11 url='https://github.com/uutils/coreutils'
12 license=('MIT')
13 depends=('glibc' 'gcc-libs')
14 makedepends=('rust' 'cargo' 'python-sphinx')
15 source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
16 sha512sums=('307f84ab58694f8216890a1755867d4b863a3722c593f7bdb6af2d6186f3464b3ed62c59a4a7dd703a8ff659a4d95c11a532b4f1fa8f107b8671394920bfa279')
17 options=('!lto')
19 prepare() {
20   cd $_pkgname-$pkgver
21   sed 's|"bin"|"builduser"|g' -i tests/by-util/test_{chgrp,chown}.rs
24 build() {
25   cd $_pkgname-$pkgver
27   make PROFILE=release
30 check() {
31   cd $_pkgname-$pkgver
33   make test \
34       PROFILE=release \
35       CARGOFLAGS=--release \
36       TEST_NO_FAIL_FAST="--no-fail-fast -- \
37         --skip test_chown::test_big_p \
38         --skip test_chgrp::test_big_p \
39         --skip test_chgrp::test_big_h"
42 package() {
43   cd $_pkgname-$pkgver
45   make install \
46       DESTDIR="$pkgdir" \
47       PREFIX=/usr \
48       MANDIR=/share/man/man1 \
49       PROG_PREFIX=uu- \
50       PROFILE=release \
51       MULTICALL=y
53   install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
56 # vim: ts=2 sw=2 et: