upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / vapoursynth-plugin-fluxsmooth / trunk / PKGBUILD
blob06dfc7523e27366fadd6439f93a709b13ae97e78
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
4 pkgname=vapoursynth-plugin-fluxsmooth
5 pkgver=2
6 pkgrel=3
7 pkgdesc='FluxSmooth plugin for VapourSynth'
8 arch=('x86_64')
9 url='https://github.com/dubhater/vapoursynth-fluxsmooth'
10 license=('None')
11 depends=('vapoursynth')
12 [[ $CARCH == 'x86_64' ]] && makedepends=('yasm')
13 source=("vapoursynth-plugin-fluxsmooth-${pkgver}.tar.gz::https://github.com/dubhater/vapoursynth-fluxsmooth/archive/v${pkgver}.tar.gz")
14 sha256sums=('975bdf16ec52c9d3ebfd487db10799c0ccb8f8c5e0e70d48df0f8067c5f24fcb')
16 build() {
17   cd vapoursynth-fluxsmooth-${pkgver}
19   export LDFLAGS="$LDFLAGS,-z,noexecstack"
21   ./autogen.sh
22   ./configure \
23     --prefix='/usr' \
24     --libdir='/usr/lib/vapoursynth'
25   make
28 package(){
29   cd vapoursynth-fluxsmooth-${pkgver}
31   make DESTDIR="${pkgdir}" install
32   install -dm 755 "${pkgdir}"/usr/share/doc/vapoursynth/plugins/FluxSmooth
33   install -m 644 readme.rst "${pkgdir}"/usr/share/doc/vapoursynth/plugins/FluxSmooth/README
36 #vim: ts=2 sw=2 et: