upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / vim-ctrlp / trunk / PKGBUILD
blob8961e6a39adb657e5c2f6327bba2be2fbf39e144
1 pkgname=vim-ctrlp
2 pkgver=1.81
3 pkgrel=1
4 pkgdesc="Fuzzy file, buffer, mru, tag, etc finder."
5 arch=('any')
6 url="https://github.com/ctrlpvim/ctrlp.vim"
7 license=('custom:vim')
8 depends=('vim>=7.0')
9 optdepends=('ctags: for searching tags')
10 groups=('vim-plugins')
11 source=($pkgname-$pkgver.tar.gz::"https://github.com/ctrlpvim/ctrlp.vim/archive/$pkgver.tar.gz"
12         LICENSE)
13 sha256sums=('9de452e7c3c2e1831007fdc69149368f9169837681ff46a09e1bca8cbdbebf93'
14             '446c67d93c43addf076fe103a71844c2d875d478f82186436567dd221f2652f3')
16 package() {
17         cd "${srcdir}/ctrlp.vim-$pkgver"
19         installpath="${pkgdir}/usr/share/vim/vimfiles"
21         install -d "$installpath/autoload/ctrlp/"
22         install -Dm644 autoload/ctrlp/* "$installpath/autoload/ctrlp/"
23         install -Dm644 autoload/ctrlp.vim "$installpath/autoload/ctrlp.vim"
24         install -Dm644 doc/ctrlp.txt "$installpath/doc/ctrlp.txt"
25         install -Dm644 plugin/ctrlp.vim "$installpath/plugin/ctrlp.vim"
26         install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"