1 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
2 # Modified from extra/xdg-desktop-portal-kde; original contributors:
3 # Contributor: Antonio Rojas <arojas@archlinux.org>
5 pkgname=xdg-desktop-portal-lxqt
8 pkgdesc='A backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt'
10 url='https://github.com/lxqt/xdg-desktop-portal-lxqt'
12 depends=(qt5-base kwindowsystem xdg-desktop-portal libfm-qt)
14 provides=(xdg-desktop-portal-impl)
15 source=("https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"{,.asc})
16 sha256sums=('e55c6c87186ca39272efab6a3b79c418b6e16d09d8748dd0ad05165a18e7b2b0'
19 "19DFDF3A579BD509DBB572D8BE793007AD22DF7E" # Pedram Pourang <tsujan2000@gmail.com>
23 cmake -B build -S $pkgname-$pkgver \
24 -DCMAKE_INSTALL_LIBEXECDIR=lib \
25 -DCMAKE_INSTALL_PREFIX=/usr
30 DESTDIR="$pkgdir" cmake --install build