upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / xplot / trunk / PKGBUILD
blob7c094c2c73c0078775153d5961d9420059d139ad
1 # Maintainer:  Baptiste Jonglez <baptiste--aur at jonglez dot org>
2 # Contributor: Jan-Erik Rediger <badboy at archlinux dot us>
4 pkgname=xplot
5 pkgver=0.90.7.1
6 pkgrel=8
7 pkgdesc="Reads from a xpl file to generate plots"
8 arch=('x86_64')
9 url="http://www.xplot.org/"
10 license=('MIT')
11 depends=('libx11' 'perl')
12 source=("http://www.xplot.org/xplot/$pkgname-$pkgver.tar.gz")
13 md5sums=('755e32f8ae429f1c546fdeee7c28c92e')
14 sha256sums=('01ceac45540f2d01e6ffe368cc0e950f4bb7fe1d235efde5349a09199e662240')
16 build() {
17   cd "${srcdir}/${pkgname}-${pkgver}"
19   ./configure --prefix="${pkgdir}/usr"
20   sed -e "s|mandir = \$(exec_prefix)/man/man1|mandir = \$(exec_prefix)/share/man/man1|" -i Makefile
21   make
24 package() {
25   cd "${srcdir}/${pkgname}-${pkgver}"
27   make install
28   mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}/"
29   sed -n '2,31p' "${srcdir}/${pkgname}-${pkgver}/xplot.c" > "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"