upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / yabause-gtk / trunk / PKGBUILD
blob0bfa05dd48bb77ce722c39dfde4f719879aa3115
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Harley Laue <losinggeneration@gmail.com>
3 # Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
4 # Contributor: Anton Shestakov <engoredi@ya.ru>
5 # Contributor: Tiago Camargo <tcamargo@gmail.com>
6 # Contributor: robb_force <robb_force@holybuffalo.net>
8 pkgname=yabause-gtk
9 pkgver=0.9.15
10 pkgrel=3
11 pkgdesc='A Sega Saturn emulator'
12 arch=('x86_64')
13 url="https://yabause.org/"
14 license=('GPL')
15 depends=('freeglut' 'glew' 'gtkglext' 'openal' 'sdl2')
16 makedepends=('cmake')
17 conflicts=('yabause-qt')
18 source=("https://download.tuxfamily.org/yabause/releases/${pkgver}/yabause-${pkgver}.tar.gz"
19         'rwx.patch')
20 sha256sums=('4334c43fe0f3ff297bac8e91f4e059fe5fd276291faff2489e37b5b3a4ccc2b2'
21             'd29997d3249683081a2687f31e777f917093101d56815d22103aaaf22ac786b1')
23 prepare() {
24   cd yabause-${pkgver}
26   patch -Np1 -i ../rwx.patch
29 build() {
30   cd yabause-${pkgver}
32   if [[ -d build ]]; then
33     rm -rf build
34   fi
35   mkdir build && cd build
37   cmake .. \
38     -DCMAKE_BUILD_TYPE='Release' \
39     -DCMAKE_INSTALL_PREFIX='/usr' \
40     -DYAB_PORTS='gtk' \
41     -DYAB_NETWORK='ON' \
42     -DYAB_OPTIMIZED_DMA='ON' \
43     -DSH2_DYNAREC=OFF    # https://github.com/Yabause/yabause/issues/270
44   make
47 package() {
48   cd yabause-${pkgver}/build
50   make DESTDIR="${pkgdir}" install
53 # vim: ts=2 sw=2 et: