upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / yubikey-full-disk-encryption / trunk / PKGBUILD
blobd98c4702c5e2fc61bbf46f746f960cd8a84973cf
1 # Maintainer: Anatol Pomozov
2 # Contributor: therojam <archlinux@therojam.xyz>
4 pkgname=yubikey-full-disk-encryption
5 _commit=dcaac005b10eac132ac663c268318bd909bf027c
6 pkgver=r155.dcaac00
7 pkgrel=1
8 pkgdesc='Use YubiKey to unlock a LUKS partition'
9 arch=(any)
10 url='https://github.com/agherzan/yubikey-full-disk-encryption'
11 license=(Apache)
12 depends=(yubikey-personalization cryptsetup)
13 optdepends=('ykchalresp-nfc: NFC support'
14             'udisks2: use ykfde-open without root'
15             'expect: use ykfde-open without root')
16 makedepends=(git)
17 backup=(etc/ykfde.conf)
18 source=(git+https://github.com/agherzan/yubikey-full-disk-encryption.git#commit=$_commit)
19 sha256sums=('SKIP')
21 pkgver() {
22   cd yubikey-full-disk-encryption
23   printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
26 package() {
27   cd yubikey-full-disk-encryption
28   make DESTDIR="$pkgdir" install