upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / zps / trunk / PKGBUILD
blob2d6a198ac9550bd4a1743333857a644edf19b30a
1 # Maintainer: Orhun Parmaksız <orhun@archlinux.org>
3 pkgname=zps
4 pkgver=1.2.8
5 pkgrel=1
6 pkgdesc="A small utility for listing and cleaning up zombie processes"
7 arch=('x86_64')
8 url="https://github.com/orhun/zps"
9 license=('GPL3')
10 depends=('glibc')
11 makedepends=('cmake')
12 source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
13 sha512sums=('660a4c92c62391e555d1fe526f200f5610e02809186b3fa2e6aa474fb164c32616532c3248f62ab5db7fbc13e5261476dc0fdb28dbad63162c0d6193660cdbe6')
15 build() {
16   cd "$pkgname-$pkgver"
17   mkdir -p build && cd build/
18   cmake ../ -DCMAKE_INSTALL_PREFIX=/usr
19   make
22 package() {
23   cd "$pkgname-$pkgver/build"
24   make DESTDIR="$pkgdir" install
25   install -Dm 644 "../README.md" -t "$pkgdir/usr/share/doc/$pkgname"
26   install -Dm 644 "../man/$pkgname.1" -t "$pkgdir/usr/share/man/man1"
27   install -Dm 644 "../.application/$pkgname.desktop" -t "$pkgdir/usr/share/applications"
30 # vim: ts=2 sw=2 et: