upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / gnome-latex / repos / community-x86_64 / PKGBUILD
blob3819ced9383b2814fc0d45512807002ad98cac32
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Tobias Bohrmann (PlainTextField) <honeypot.carbage@aechelon.de>
3 # Contributor: Bernd Prünster (JesusMcCloud) <aur@berndpruenster.org>
5 pkgname=gnome-latex
6 pkgver=3.44.0
7 pkgrel=1
8 pkgdesc='LaTeX editor for the GNOME desktop'
9 arch=('x86_64')
10 url='https://wiki.gnome.org/Apps/GNOME-LaTeX'
11 license=('GPL3')
12 depends=('gsettings-desktop-schemas' 'gspell' 'libgee' 'tepl')
13 makedepends=('appstream-glib' 'autoconf-archive' 'git' 'gtk-doc' 'gobject-introspection' 'intltool'
14              'vala' 'yelp-tools')
15 optdepends=('texlive-core: build LaTeX documents')
16 options=('debug')
17 _commit=8083f0476247feb29afac2682ee640dd18b8a6cf  # tags/3.44.0^0
18 source=("git+https://gitlab.gnome.org/swilmet/gnome-latex.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd $pkgname
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd $pkgname
28   NOCONFIGURE=1 ./autogen.sh
31 build() {
32   cd $pkgname
33   ./configure --prefix=/usr --enable-gtk-doc
34   make
37 check() {
38   make -C $pkgname check
41 package() {
42   cd $pkgname
43   make DESTDIR="$pkgdir" install