upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / hashdeep / trunk / PKGBUILD
blobaed8920f29dc8004f7215326da61ab653ddb86f3
1 # Maintainer: Jonas Witschel <diabonas@archlinux.org>
2 # Contributor: Alad Wenter <alad@mailbox.org>
3 # Contributor: Uffe Jakobsen <uffe@uffe.org>
4 pkgname=hashdeep
5 pkgver=4.4
6 pkgrel=6
7 pkgdesc="cross-platform tools to message digests for any number of files"
8 arch=('x86_64')
9 url="https://github.com/jessek/hashdeep"
10 license=('GPL' 'custom')
11 depends=('gcc-libs')
12 source=("$pkgname-$pkgver.tar.gz::https://github.com/jessek/hashdeep/archive/refs/tags/v$pkgver.tar.gz"
13         "hashdeep-4.4-fix-errors-found-by-clang.patch::https://github.com/jessek/hashdeep/commit/6ef69a26126ee4e69a25392fd456b8a66c51dffd.patch")
14 sha256sums=('ad78d42142f9a74fe8ec0c61bc78d6588a528cbb9aede9440f50b6ff477f3a7f'
15             '7a7fbca4339ca64589386d12d560c04e0929da9065b7e9c0dd1f441bc6fc0fbc')
17 prepare() {
18     cd "$pkgname-$pkgver"
20     # Fix compilation with GCC 11
21     patch --forward --strip=1 --input="$srcdir/hashdeep-4.4-fix-errors-found-by-clang.patch"
23     ./bootstrap.sh
26 build() {
27     cd "$pkgname-$pkgver"
28     ./configure --prefix=/usr
29     make
32 package() {
33     cd "$pkgname-$pkgver"
34     make DESTDIR="$pkgdir/" install
36     mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
37     install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"