1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=concurrent-extra
4 pkgname=haskell-concurrent-extra
7 pkgdesc="Extra concurrency primitives"
8 url="https://github.com/basvandijk/concurrent-extra"
11 depends=('ghc-libs' 'haskell-unbounded-delays')
12 makedepends=('ghc' 'haskell-hunit' 'haskell-async' 'haskell-random' 'haskell-test-framework'
13 'haskell-test-framework-hunit')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('040e6db9e0147de9929661759930f1566a7250add4c7f65b04dc6e070c991df9')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-concurrent-extra --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 # https://github.com/basvandijk/concurrent-extra/issues/12
36 runhaskell Setup test || echo "Tests failed"
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE