upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / haskell-configfile / trunk / PKGBUILD
blob7eb734017e419d7923469e447951a00a9a8ac7fd
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ConfigFile
4 pkgname=haskell-configfile
5 pkgver=1.1.4
6 pkgrel=27
7 pkgdesc="Configuration file reading & writing"
8 url="http://software.complete.org/configfile"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-missingh')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('ae087b359ff2945a62b671449227e0a811d143ee651179f4e7e9c66548e0f514')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie' \
24     -f-buildtests
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $_hkgname-$pkgver
35   runhaskell Setup test --show-details=direct
38 package() {
39   cd $_hkgname-$pkgver
41   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43   runhaskell Setup copy --destdir="$pkgdir"
44   install -D -m644 COPYRIGHT -t "$pkgdir"/usr/share/licenses/$pkgname/
45   rm -f "$pkgdir"/usr/share/doc/$pkgname/COPYRIGHT