upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / haskell-descriptive / trunk / PKGBUILD
blob9725a5d0964b1738457fe2b69f58533a15571ee8
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=descriptive
5 pkgname=haskell-descriptive
6 pkgver=0.9.5
7 pkgrel=343
8 pkgdesc="Self-describing consumers/parsers; forms, cmd-line args, JSON, etc."
9 url="https://github.com/chrisdone/descriptive"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-aeson" "haskell-bifunctors" "haskell-scientific"
13          "haskell-vector")
14 makedepends=('ghc')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('259761b86f0f0c517baf80942e81820e6665b45548a3e7970a19d0ce344781f48e9f35b73748a6d5fe7afcc35bc5d0feb7634e56cb408d03d92e1d0cac1fdd1b')
18 build() {
19     cd $_hkgname-$pkgver
20     
21     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
23         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 package() {
32     cd $_hkgname-$pkgver
33     
34     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36     runhaskell Setup copy --destdir="$pkgdir"
37     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
38     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE