upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / haskell-iospec / trunk / PKGBUILD
blob5079fd298add23e7d657680ed99fb69722c87802
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=IOSpec
4 pkgname=haskell-iospec
5 pkgver=0.3.1.1
6 pkgrel=24
7 pkgdesc="A pure specification of the IO monad."
8 url="https://github.com/lambdabot/IOSpec"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-quickcheck' 'haskell-stream')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('345c14a6f24b526cdf10a51b808c43305b9d03dad8a3902bd1c0922aad3ccef0')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie' 
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"
43   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE