1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
4 pkgname=jupyter-widgetsnbextension
8 pkgdesc='Interactive HTML widgets for Jupyter notebooks'
10 url='https://pypi.python.org/pypi/widgetsnbextension'
12 depends=(jupyter-notebook python-ipywidgets)
13 makedepends=(python-build python-installer python-setuptools python-wheel)
14 source=(https://pypi.io/packages/source/w/widgetsnbextension/widgetsnbextension-$pkgver.tar.gz)
15 sha256sums=('ea67c17a7cd4ae358f8f46c3b304c40698bc0423732e3f273321ee141232c8be')
18 cd widgetsnbextension-$pkgver
19 python -m build --wheel --no-isolation
23 cd widgetsnbextension-$pkgver
24 python -m installer --destdir="$pkgdir" dist/*.whl
25 mv "$pkgdir/usr/etc" "$pkgdir/etc"
26 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname