upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / jupyter-widgetsnbextension / repos / community-any / PKGBUILD
blobcbd7ff53c739e7a587e6f22b260bd6fff0433d00
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Kyle Keen <keenerd@gmail.com>
4 pkgname=jupyter-widgetsnbextension
5 pkgver=4.0.7
6 pkgrel=2
7 epoch=1
8 pkgdesc='Interactive HTML widgets for Jupyter notebooks'
9 arch=(any)
10 url='https://pypi.python.org/pypi/widgetsnbextension'
11 license=(BSD)
12 depends=(jupyter-notebook python-ipywidgets)
13 makedepends=(python-build python-installer python-setuptools python-wheel)
14 source=(https://pypi.io/packages/source/w/widgetsnbextension/widgetsnbextension-$pkgver.tar.gz)
15 sha256sums=('ea67c17a7cd4ae358f8f46c3b304c40698bc0423732e3f273321ee141232c8be')
17 build() {
18   cd widgetsnbextension-$pkgver
19   python -m build --wheel --no-isolation
22 package() {
23   cd widgetsnbextension-$pkgver
24   python -m installer --destdir="$pkgdir" dist/*.whl
25   mv "$pkgdir/usr/etc" "$pkgdir/etc"
26   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname