1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
6 pkgdesc='A tracker for making C64/NES/Amiga-style chiptunes on a modern platform'
8 url='https://github.com/LTVA1/klystrack'
18 _commit='dddea70c9378ab9c3dbd09e5a0283295fcce2ede'
21 "$pkgname::git+$url#commit=$_commit"
22 'github.com-LTVA1-klystron::git+https://github.com/LTVA1/klystron'
23 'update-desktop-file.patch'
24 'repro-klystrack-plus.patch'
25 'repro-klystron.patch'
29 '5543cae63098a27ee6539cf92f06a87756bbfcbad0e6000eed8c5ad32fb354f18439730d021a278ffd8d4359b8c6847d8c0ae06a882faf1887b8a4c1c912ec50'
30 '761ef03457b9ea2009b8483608a99befe3444641ef5f351ab3d3d33271bedca1b32a2cec8c9d6fbec0a6d871134915cd5c11111c48b5015019021b61388e0a2c'
31 'c22be63b5103b9c9c21366df6d0a76b59d3f39054204a56845fe105de54240fc0f269db48330fb52269e9b32bef147bd529c39d1f26a088386c70f5d702168ff')
37 git describe --tags | sed -e 's/^v//' -e 's/-/./g'
43 # prepare git submodules
45 git config submodule.klystron.url "$srcdir/github.com-LTVA1-klystron"
46 git -c protocol.file.allow=always submodule update
48 # update desktop file to point to klystrack-plus,
49 # just in case users have the original klystrack installed
50 patch --strip 1 --input "$srcdir/update-desktop-file.patch"
52 # first pass at ensuring reproducibility by using
53 # git commit date instead of date
54 patch --strip 1 --input "$srcdir/repro-klystrack-plus.patch"
55 patch --directory klystron --strip 1 --input "$srcdir/repro-klystron.patch"
61 make CFG=release RES_PATH=/usr/lib/klystrack-plus
67 make DESTDIR="$pkgdir" CFG=release RES_PATH=/usr/lib/klystrack-plus install
70 mv -v "$pkgdir/usr/bin/"klystrack{,-plus}
73 install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
76 cp -vr examples "$pkgdir/usr/share/$pkgname"
79 install -vDm644 doc/klystrack.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
82 install -vDm644 linux/klystrack.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
85 install -vDm644 icon/256x256.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
88 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE