1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=libretro-dolphin
6 pkgdesc='Nintendo GC/Wii core'
8 url=https://github.com/libretro/dolphin
43 _commit=2f4b0f7902257d40a054f60b2c670d6e314f2a04
45 libretro-dolphin::git+https://github.com/libretro/dolphin.git#commit=${_commit}
46 libretro-dolphin-missing-headers.patch
49 '5b4ca6d1dc6af7a3afd014700305616d9e3e0f139f128cfa2af6cff3194a36ef9a591faaefbb8491d71f646187ee79e6fb5f29e9f57eeaf4e82768e814516f1a')
53 patch -Np1 -i ../libretro-dolphin-missing-headers.patch
58 git rev-list --count HEAD
64 cmake -S libretro-dolphin -B build -G Ninja \
65 -DCMAKE_BUILD_TYPE=None \
66 -DCMAKE_INSTALL_PREFIX=/usr \
72 -DUSE_SHARED_ENET=ON \
78 install -Dm 644 build/dolphin_libretro.so -t "${pkgdir}"/usr/lib/libretro/