upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / libretro-dolphin / trunk / PKGBUILD
blob18726863927e74fb1b0cd718997ae24f6abe20ab
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=libretro-dolphin
4 pkgver=33042
5 pkgrel=2
6 pkgdesc='Nintendo GC/Wii core'
7 arch=(x86_64)
8 url=https://github.com/libretro/dolphin
9 license=(GPL2)
10 groups=(libretro)
11 depends=(
12   bluez-libs
13   bzip2
14   enet
15   gcc-libs
16   glibc
17   libevdev
18   libfmt.so
19   libgl
20   libglvnd
21   libhidapi-hidraw.so
22   libpng
23   libretro-core-info
24   libudev.so
25   libusb-1.0.so
26   libx11
27   libxi
28   libxrandr
29   lzo
30   sfml
31   xz
32   zlib
33   zstd
35 makedepends=(
36   clang
37   cmake
38   git
39   mesa
40   ninja
41   python
43 _commit=2f4b0f7902257d40a054f60b2c670d6e314f2a04
44 source=(
45   libretro-dolphin::git+https://github.com/libretro/dolphin.git#commit=${_commit}
46   libretro-dolphin-missing-headers.patch
48 b2sums=('SKIP'
49         '5b4ca6d1dc6af7a3afd014700305616d9e3e0f139f128cfa2af6cff3194a36ef9a591faaefbb8491d71f646187ee79e6fb5f29e9f57eeaf4e82768e814516f1a')
51 prepare() {
52   cd libretro-dolphin
53   patch -Np1 -i ../libretro-dolphin-missing-headers.patch
56 pkgver() {
57   cd libretro-dolphin
58   git rev-list --count HEAD
61 build() {
62   export CC=clang
63   export CXX=clang++
64   cmake -S libretro-dolphin -B build -G Ninja \
65     -DCMAKE_BUILD_TYPE=None \
66     -DCMAKE_INSTALL_PREFIX=/usr \
67     -DENABLE_LTO=ON \
68     -DENABLE_NOGUI=OFF \
69     -DENABLE_QT=OFF \
70     -DENABLE_TESTS=OFF \
71     -DLIBRETRO=ON \
72     -DUSE_SHARED_ENET=ON \
73     -Wno-dev
74   cmake --build build
77 package() {
78   install -Dm 644 build/dolphin_libretro.so -t "${pkgdir}"/usr/lib/libretro/
81 # vim: ts=2 sw=2 et: