upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / mlite / trunk / PKGBUILD
blob9935fd4027a11870285838029e548b17b1a4f288
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=mlite
4 pkgver=0.4.0
5 pkgrel=1
6 pkgdesc="Useful classes originating from MeeGo Touch"
7 arch=('x86_64')
8 url="https://github.com/sailfishos/mlite"
9 license=('LGPL')
10 depends=('qt5-base' 'dconf')
11 makedepends=('qt5-tools')
12 source=("https://github.com/sailfishos/mlite/archive/$pkgver/$pkgname-$pkgver.tar.gz")
13 sha512sums=('c271081e219bacf53224c583b53e38a2ca32174e91b4485b529a21dfe179f7306c2aed0a65091cbd8b60d1fe2971d59fd264dbc8bec32461525eb01d39ab25ee')
15 prepare() {
16   cd mlite-$pkgver
17   sed -i -e 's|/usr/libexec|/usr/lib|' \
18       tools/mliteremoteaction/mliteremoteaction.pro \
19       tools/mliteremoteaction/main.cpp \
20       src/mremoteaction.cpp
23 build() {
24   cd mlite-$pkgver
25   qmake-qt5 VERSION=$pkgver
26   make
29 package() {
30   cd mlite-$pkgver
31   make INSTALL_ROOT="$pkgdir" install
33   # Remove tests
34   rm -r "$pkgdir/opt"