upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / openfire / trunk / PKGBUILD
blob6844bb2128ea600e87acf8142f7908b484845907
1 # Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
2 # Contributor: Pierre Schmitz <pierre@archlinux.de>
4 pkgname=openfire
5 pkgver=4.7.4
6 pkgrel=1
7 pkgdesc="High performance XMPP (Jabber) server."
8 arch=('any')
9 url='https://www.igniterealtime.org/projects/openfire/'
10 license=('APACHE')
11 depends=('java-runtime-headless<19')
12 makedepends=('maven' 'jre11-openjdk-headless' 'jdk11-openjdk')
13 backup=('etc/conf.d/openfire'
14         'etc/openfire/openfire.xml'
15         'etc/openfire/security.xml'
16         'etc/openfire/crowd.properties'
17         'etc/openfire/security/truststore'
18         'etc/openfire/security/client.truststore'
19         'etc/openfire/security/keystore')
20 source=("$pkgname-$pkgver.tar.gz::https://github.com/igniterealtime/Openfire/archive/refs/tags/v$pkgver.tar.gz"
21         'openfire.conf'
22         'openfire.service'
23         'user.conf'
24         'tmpfile.conf')
25 sha256sums=('5eb22e165d1de0a1e601efbd356266a6823fafc866b684500ec90af1ba764ab9'
26             'c8a612abee90bdc9a2869e562a4bbbf596159c60adcd23368833a0e2ca27c1d4'
27             '3e7bca77161777daefd3533d4d6f42ff7970533c887d6f4b7f1c9fdcf7771d05'
28             '8bfa51cf8cc88fc69547a8f6e9e3fb242926ca2a100659363e1a6b332f223ba9'
29             'c63396991984a067d05e21094a664255d6aed2bf294bddd3885a7da75472b886')
31 build() {
32         cd "$srcdir"/Openfire-$pkgver
33         make
36 package() {
37         cd "$pkgdir"
38         install -dm755 usr/lib usr/share/openfire/resources usr/share/doc
39         install -dm750 etc/openfire
41         cd "$srcdir"
42         install -Dm644 openfire.conf "$pkgdir"/etc/conf.d/openfire
43         install -Dm644 openfire.service "$pkgdir"/usr/lib/systemd/system/openfire.service
44         install -Dm644 user.conf "$pkgdir"/usr/lib/sysusers.d/openfire.conf
45         install -Dm644 tmpfile.conf "$pkgdir"/usr/lib/tmpfiles.d/openfire.conf
47         cd Openfire-$pkgver/distribution/target/distribution-base
49         cp -R conf/* "$pkgdir"/etc/openfire/
51         cp -R resources/security "$pkgdir"/etc/openfire/
52         ln -s /etc/openfire/security "$pkgdir"/usr/share/openfire/resources/security
54         cp -R plugins "$pkgdir"/usr/share/openfire/
55         cp -R resources/{database,spank,nativeAuth} "$pkgdir"/usr/share/openfire/resources/
56         rm -rf "$pkgdir"/usr/share/openfire/resources/nativeAuth/{osx,win}*
57         cp -R lib "$pkgdir"/usr/lib/openfire
58         cp -R documentation "$pkgdir"/usr/share/doc/openfire