upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / pantheon-code / trunk / PKGBUILD
blob384156c0180125e3b6a587825e035378f2af0115
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
4 pkgname=pantheon-code
5 pkgver=7.0.0
6 pkgrel=1
7 pkgdesc='The Pantheon Text Editor'
8 arch=(x86_64)
9 url=https://github.com/elementary/code
10 license=(GPL3)
11 groups=(pantheon)
12 depends=(
13   editorconfig-core-c
14   glib2
15   gtk3
16   gtksourceview4
17   libgee
18   libgit2-glib
19   libgranite.so
20   libhandy-1.so
21   libpeas
22   pango
23   polkit
25 makedepends=(
26   cmake
27   git
28   gobject-introspection
29   gtkspell3
30   intltool
31   libsoup
32   meson
33   vala
34   vte3
35   webkit2gtk
37 optdepends=(
38   'gtkspell3: Spell Check plugin'
39   'libsoup: Pastebin plugin'
40   'vala: Outline plugin'
41   'vte3: Terminal plugin'
42   'webkit2gtk: Browser Preview plugin'
44 _tag=789487b06acc31aa62527176a79fbd5b56632424
45 source=(pantheon-code::git+https://github.com/elementary/code.git#tag=${_tag})
46 b2sums=(SKIP)
48 pkgver() {
49   cd pantheon-code
50   git describe --tags
53 build() {
54   arch-meson pantheon-code build
55   meson compile -C build
58 package() {
59   meson install -C build --destdir "${pkgdir}"
62 # vim:set ts=2 sw=2 et: