upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / perl-xml-filter-buffertext / trunk / PKGBUILD
blob074c3e820903864b6f01e266a03fd47a071ffad7
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
2 # Contributor: Ondrej Kucera <ondrej.kucera@centrum.cz>
4 pkgname=perl-xml-filter-buffertext
5 pkgver=1.01
6 pkgrel=9
7 pkgdesc="XML-Filter-BufferText perl module (filter to put all characters() in one event)"
8 arch=("any")
9 url="https://search.cpan.org/dist/XML-Filter-BufferText/"
10 license=("GPL" "PerlArtistic")
11 depends=('perl>=5.10.0' 'perl-xml-sax')
12 options=(!emptydirs)
13 source=(https://search.cpan.org/CPAN/authors/id/R/RB/RBERJON/XML-Filter-BufferText-$pkgver.tar.gz)
14 sha256sums=('8fd2126d3beec554df852919f4739e689202cbba6a17506e9b66ea165841a75c')
16 build() {
17   cd "$srcdir"/XML-Filter-BufferText-${pkgver}
18   # Install module into the vendor directories.
19   perl Makefile.PL INSTALLDIRS=vendor
20   make
21   make test
24 package() {
25   cd "$srcdir"/XML-Filter-BufferText-${pkgver}
26   make DESTDIR="$pkgdir" install
28   # Remove .packlist and perllocal.pod files.
29   find "$pkgdir" -name '.packlist' -delete
30   find "$pkgdir" -name 'perllocal.pod' -delete