upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / python-blessed / repos / community-any / PKGBUILD
blobd6c68c9616a77ed8508aea7db108045d995d60dd
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Tatsuyuki Ishi <ishitatsuyuki@gmail.com>
4 pkgname=python-blessed
5 pkgver=1.20.0
6 pkgrel=3
7 pkgdesc='A thin, practical wrapper around terminal styling, screen positioning, and keyboard input'
8 arch=(any)
9 url=https://github.com/jquast/blessed
10 license=(GPL)
11 depends=(
12   python-six
13   python-wcwidth
15 makedepends=(
16   git
17   python-setuptools
19 checkdepends=(
20   python-tox
22 _tag=d404d8ccde9ba900bc968c1213b915a691581603
23 source=(git+https://github.com/jquast/blessed.git#tag=${_tag})
24 sha256sums=(SKIP)
26 pkgver() {
27   cd blessed
29   git describe --tags
32 build() {
33   cd blessed
35   python setup.py build
38 check() {
39   cd blessed
41   tox -e py310
44 package() {
45   cd blessed
47   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
50 # vim: ts=2 sw=2 et: