2 # Contributor: Pekka Ristola <pekkarr [at] protonmail [dot] com>
3 # Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
6 pkgname=python-$_pkgname
9 pkgdesc='Rapid fuzzy string matching in Python using various string metrics'
11 url='https://github.com/maxbachmann/rapidfuzz'
14 makedepends=(python-build python-installer python-scikit-build rapidfuzz-cpp)
15 checkdepends=(python-hypothesis python-pandas python-pytest)
16 optdepends=(python-numpy)
17 source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
18 sha256sums=('4c1d895d16f62e9ac88d303eb918d90a390bd712055c849e01c558b7ae0fa908')
22 RAPIDFUZZ_BUILD_EXTENSION=1 \
23 python -m build --wheel --no-isolation
28 python -m venv --system-site-packages test-env
29 test-env/bin/python -m installer dist/*.whl
30 test-env/bin/python -m pytest
35 python -m installer --destdir="$pkgdir" dist/*.whl
37 install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
38 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname