1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: David Runge <dvzrv@archlinux.org>
6 _commit=2f3f75e8c2117ae2ff118219dc7a118eb8f52b0b # refs/tags/v0.30.0
8 pkgdesc='Command-line frontends for Sequoia'
9 url='https://sequoia-pgp.org/'
19 'nettle' 'libnettle.so' 'libhogweed.so'
29 source=("git+https://gitlab.com/sequoia-pgp/sequoia-sq.git#tag=$_commit?signed")
32 D2F2C5D45BE9FDE6A4EE0AAF31855247603831FD # justus@sequoia-pgp.org
33 CBCD8F030588653EEDD7E2659B7DD433F254904A # justus@sequoia-pgp.org
34 8F17777118A33DDA9BA48E62AACB3243630052D9 # Neal H. Walfield <neal@sequoia-pgp.org>
39 export RUSTUP_TOOLCHAIN=stable
40 cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
45 export CARGO_TARGET_DIR=../target
46 export RUSTUP_TOOLCHAIN=stable
47 # NOTE: we select specific (default) features, as there are multiple crypto backends
48 cargo build --release --frozen --features 'default'
54 # NOTE: we use a different target dir, as otherwise cargo test --release alters the sq binary
55 # https://gitlab.com/sequoia-pgp/sequoia-sq/-/issues/96
56 export CARGO_TARGET_DIR=../target-test
57 export RUSTUP_TOOLCHAIN=stable
58 cargo test --release --frozen --features 'default'
62 install -Dm 755 target/release/sq -t "${pkgdir}/usr/bin"
64 install -Dm 644 target/sq.bash "${pkgdir}/usr/share/bash-completion/completions/sq"
65 install -Dm 644 target/_sq -t "${pkgdir}/usr/share/zsh/site-functions"
66 install -Dm 644 target/sq.fish -t "${pkgdir}/usr/share/fish/vendor_completions.d"
68 for manpage in target/release/build/$pkgname-*/out/*.1; do
69 install -Dm 644 $manpage -t "${pkgdir}/usr/share/man/man1/"