upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / supercollider / trunk / PKGBUILD
blobca6e60ebc8dbe6ec1606408eb6b9faee9ec27eb6
1 # Maintainer: Brett Cornwall <ainola@archlinux.org>
2 # Maintainer: David Runge <dvzrv@archlinux.org>
3 # Contributor: speps <speps at aur dot archlinux dot org>
4 # Contributor: osc <farid at archlinux-br.org>
6 _name=SuperCollider
7 pkgname=supercollider
8 pkgver=3.13.0
9 pkgrel=2
10 pkgdesc="Platform for audio synthesis and algorithmic composition"
11 arch=(x86_64)
12 url="https://supercollider.github.io"
13 license=(GPL3)
14 groups=(pro-audio)
15 depends=(
16   gcc-libs
17   glibc
18   libx11
19   qt5-base
20   qt5-svg
21   qt5-webengine
22   qt5-websockets
24 makedepends=(
25   abletonlink
26   alsa-lib
27   avahi
28   boost
29   cmake
30   emacs
31   fftw
32   libsndfile
33   qt5-tools
34   readline
35   systemd-libs
36   yaml-cpp
38 checkdepends=(xorg-server-xvfb)
39 optdepends=(
40   'emacs: emacs interface'
41   'gedit: gedit interface'
42   'sc3-plugins: additional extension plugins for scsynth'
44 provides=(libscsynth.so "sclang=$pkgver" "scsynth=$pkgver")
45 source=(
46     https://github.com/$pkgname/$pkgname/releases/download/Version-$pkgver/$_name-$pkgver-Source.tar.bz2{,.asc}
48 install=$pkgname.install
49 sha512sums=('a60a128f7646f077f91adae666fa4014529aa9df78cf0dfe5d68c9bd6447f008af7da2970b8736f3f29d0adbaf67bce680a8201fcbe7e1aba29c3499a57f89cd'
50             'SKIP')
51 b2sums=('a5e57a17f93e40848b2044ee0791179f857d144eabb7f4d74580b2eebd49a31d6ec671a0526236c5b906aadeb455e5a7ad18cacb79ed214076d6bceca39ea2ae'
52         'SKIP')
53 validpgpkeys=('2E1C4FC2F6BB58FA157B21B8064B501EB7405F04') # Marcin PÄ…czkowski (dyfer)
56 build() {
57   local cmake_options=(
58     -B build
59     -D CMAKE_INSTALL_PREFIX=/usr
60     -D CMAKE_BUILD_TYPE=None
61     -D Boost_NO_BOOST_CMAKE=ON
62     -D LIBSCSYNTH=ON
63     -D FORTIFY=ON
64     -D SYSTEM_ABLETON_LINK=ON
65     -D SYSTEM_BOOST=ON
66     -D SYSTEM_YAMLCPP=ON
67     -D SC_VIM=OFF
68     -S $_name-$pkgver-Source
69     -W no-dev
70   )
71   export CFLAGS+=" -DNDEBUG"
72   export CXXFLAGS+=" -DNDEBUG"
73   cmake "${cmake_options[@]}"
74   cmake --build build --verbose
77 check() {
78   xvfb-run make test ARGS="-VV -d -j1" -C build
81 package() {
82   depends+=(
83     alsa-lib libasound.so
84     avahi libavahi-common.so libavahi-client.so
85     boost-libs libboost_{filesystem,program_options,thread}.so
86     fftw libfftw3f.so
87     jack libjack.so
88     libsndfile libsndfile.so
89     readline libreadline.so
90     systemd-libs libudev.so
91     yaml-cpp libyaml-cpp.so
92   )
94   DESTDIR="$pkgdir" cmake --install build
95   install -vDm 644 $_name-$pkgver-Source/{AUTHORS,{CHANGELOG,README,README_LINUX}.md} -t "$pkgdir/usr/share/doc/$pkgname/"