1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Daniel M. Capella <polyzen@archlinux.org>
3 # Contributor: Bruno Galeotti <bgaleotti at gmail dot com>
9 pkgdesc='JavaScript with syntax for types'
11 url=http://www.typescriptlang.org
14 makedepends=('npm' 'rsync')
15 source=("https://github.com/microsoft/$_name/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
16 b2sums=('20565a208225fb9fcd5b5532296f94bf870b0452fb43c72a044e52e3a2e4a6f2af20119dbcb50f996c631ff87821c298c72fddd1289919f4463313c35b322049')
34 install -d "$pkgdir"/usr/{bin,lib/node_modules/$pkgname}
35 ln -s ../lib/node_modules/$pkgname/bin/{tsc,tsserver} "$pkgdir"/usr/bin
38 rsync -r --exclude .gitattributes README.md SECURITY.md bin lib package.json \
39 "$pkgdir"/usr/lib/node_modules/$pkgname
40 install -Dt "$pkgdir"/usr/share/licenses/$pkgname ThirdPartyNoticeText.txt