upgpkg: ufw 0.36.2-1
[ArchLinux/community.git] / woob / trunk / PKGBUILD
blob5a2199a0ee2308be11cb05480a7247a2d9d49016
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 pkgname=woob
4 pkgver=3.5
5 pkgrel=1
6 pkgdesc="Core library and modules for Web outside of Browsers"
7 arch=(any)
8 url="https://woob.tech/"
9 license=(LGPL3)
10 depends=(
11     python-lxml
12     python-cssselect
13     python-requests
14     python-dateutil
15     python-yaml
16     python-html2text
17     python-six
18     python-unidecode
19     python-pillow
20     python-babel
21     python-simplejson
22     python-pycountry
24 optdepends=(
25     'python-colorama: CLI usage'
26     'python-prettytable: CLI output formatting'
27     'python-feedparser: required by some modules'
28     'python-jose: required by some modules'
29     'python-pycryptodome: required by some modules'
30     'python-google-api-python-client: multiple Google services like YouTube'
32 makedepends=(python-build python-installer python-setuptools python-wheel)
33 checkdepends=(python-pytest python-prettytable)
34 replaces=(weboob)
35 provides=(weboob)
36 conflicts=(weboob)
37 #source=(https://files.pythonhosted.org/packages/source/w/${pkgname}/${pkgname}-${pkgver}.tar.gz)
38 source=(https://gitlab.com/woob/woob/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
39 sha256sums=('a3927c5421a5f7af6fc21c79f8e0c7456685125eae88aede0aecb9773176d0b4')
41 build() {
42   cd ${pkgname}-${pkgver}
43   python -m build --wheel --no-isolation
46 check() {
47   cd ${pkgname}-${pkgver}
48   pytest -vv --color=yes
51 package() {
52   cd ${pkgname}-${pkgver}
53   python -m installer --destdir="${pkgdir}" dist/*.whl