1 # Maintainer: Bruno Pagani <archange@archlinux.org>
6 pkgdesc="Core library and modules for Web outside of Browsers"
8 url="https://woob.tech/"
25 'python-colorama: CLI usage'
26 'python-prettytable: CLI output formatting'
27 'python-feedparser: required by some modules'
28 'python-jose: required by some modules'
29 'python-pycryptodome: required by some modules'
30 'python-google-api-python-client: multiple Google services like YouTube'
32 makedepends=(python-build python-installer python-setuptools python-wheel)
33 checkdepends=(python-pytest python-prettytable)
37 #source=(https://files.pythonhosted.org/packages/source/w/${pkgname}/${pkgname}-${pkgver}.tar.gz)
38 source=(https://gitlab.com/woob/woob/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
39 sha256sums=('a3927c5421a5f7af6fc21c79f8e0c7456685125eae88aede0aecb9773176d0b4')
42 cd ${pkgname}-${pkgver}
43 python -m build --wheel --no-isolation
47 cd ${pkgname}-${pkgver}
48 pytest -vv --color=yes
52 cd ${pkgname}-${pkgver}
53 python -m installer --destdir="${pkgdir}" dist/*.whl