1 # Maintainer: kpcyrd <kpcyrd[at]archlinux[dot]org>
6 pkgdesc="Command line helpers for fuzzing rust"
7 url="https://github.com/rust-fuzz/cargo-fuzz"
10 license=('MIT' 'APACHE')
11 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rust-fuzz/${pkgname}/archive/${pkgver}.tar.gz")
12 sha256sums=('c5a0228271f9f65b1a55baf42ab42fd9a6266d7034069cd6ad3c2df194c34f1c')
13 b2sums=('2c0c497f78a70fb793ab82e13f1ba67f40f578eacd17fa42e9204990a08336ed5c631cfdfd44fcbb60f1670972db48787e448d106636ffd2e6692a8b1e230bd5')
16 cd "${pkgname}-${pkgver}"
17 cargo build --release --locked
21 cd "${pkgname}-${pkgver}"
22 # this is broken on linux-hardened
23 #RUSTC_BOOTSTRAP=1 cargo test --release --locked
27 cd "${pkgname}-${pkgver}"
28 install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
29 install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
30 install -Dm644 LICENSE-MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
33 # vim:set ts=2 sw=2 et: