1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
2 # Contributor: Dacoda Strack <dacoda.strack@gmail.com>
4 pkgname=cl-bordeaux-threads
5 _pkgname="${pkgname#cl-}"
8 pkgdesc='Portable shared-state concurrency for Common Lisp'
10 url='https://sionescu.github.io/bordeaux-threads/'
21 checkdepends=('sbcl' 'cl-fiveam')
22 _commit='076fe2380abbc59b06e495dc7a35aea8eb26ba3b'
24 "$pkgname::git+https://github.com/sionescu/bordeaux-threads#commit=$_commit"
28 '91273084a1ebd68bdafc7ad4904d232f07046de74684575813b25eaa145eb8b7d1c6e0a2f0a114376cbe6cc30bd59f88cffdea007d0f71d36c29288fa70f733f')
33 git describe --tags | sed -e 's/^v//' -e 's/-/.r/' -e 's/-/./g'
39 sbcl --script ../run-tests.lisp
46 install -vd "$pkgdir/usr/share/common-lisp/source/$_pkgname"
47 cp -vr src test version.sexp "$_pkgname.asd" "$pkgdir/usr/share/common-lisp/source/$_pkgname"
50 install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README site/*
53 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE