1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
4 _pkgname="${pkgname#cl-}"
5 pkgver=0.24.1.r23.gac07d76
7 pkgdesc='Common Foreign Function Interface for Common Lisp'
9 url='https://cffi.common-lisp.dev/'
22 checkdepends=('sbcl' 'cl-bordeaux-threads' 'cl-rt')
23 _commit='ac07d762d89ca03688392b4d9a4ca1784b995a99'
24 source=("$pkgname::git+https://github.com/cffi/cffi#commit=$_commit")
30 git describe --tags | sed -e 's/^v//' -e 's/-/.r/' -e 's/-/./g'
36 # add local dir so asdf can pick up library
38 -i tests/run-tests.lisp \
39 -e '/(require "asdf")/a (push (uiop/os:getcwd) asdf:*central-registry*)'
45 sbcl --script tests/run-tests.lisp
47 # delete test artifacts
48 find . -name '*.o' -delete -or -name '*.so' -delete
55 install -vd "$pkgdir/usr/share/common-lisp/source/$_pkgname"
57 examples grovel libffi src tests toolchain uffi-compat \
59 "$pkgdir/usr/share/common-lisp/source/$_pkgname"
62 install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
65 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" COPYRIGHT