1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
3 # Contributor: Xu Fasheng <fasheng.xu[AT]gmail.com>
5 pkgname=deepin-launcher
7 _commit=d0109891448d863e19af7b11ced427a11411d28e
9 pkgdesc='Deepin desktop-environment - Launcher module'
11 url="https://github.com/linuxdeepin/dde-launcher"
13 depends=('gsettings-qt' 'qt5-svg' 'qt5-x11extras' 'startdde' 'deepin-qt5integration' 'deepin-menu'
14 'deepin-daemon' 'deepin-qt-dbus-factory' 'xdg-user-dirs')
15 makedepends=('git' 'cmake' 'gmock' 'gtest' 'ninja' 'qt5-tools')
16 conflicts=('dde-launcher')
17 replaces=('dde-launcher')
19 source=("git+https://github.com/linuxdeepin/dde-launcher.git#commit=$_commit")
25 # workaround slow window mode loading
26 git cherry-pick -n 0612c1181f232eb1c7be05a40c9c951a51cd0f2a
28 # fix namespace of dregionmonitor
29 git cherry-pick -n 037fe068f42e379b0b7fd70bffdde040262ecd2d
31 sed -i 's|/usr/share/backgrounds/default_background.jpg|/usr/share/backgrounds/deepin/desktop.jpg|' src/boxframe/*.cpp
36 cmake . -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DWITHOUT_UNINSTALL_APP=
47 DESTDIR="$pkgdir" ninja install