archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / e3 / trunk / PKGBUILD
blob09ac1dff00f7a5db40105da4d16d5fbc953c5862
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Roberto Alsina <ralsina@kde.org>
4 pkgname=e3
5 pkgver=2.82
6 pkgrel=6
7 pkgdesc='Tiny editor without dependencies, written in assembly'
8 arch=(x86_64)
9 url='https://sites.google.com/site/e3editor/'
10 license=(GPL2)
11 makedepends=(yasm)
12 options=(!strip)
13 source=("$pkgname-$pkgver.tar.gz::https://drive.google.com/uc?export=download&id=1ZNWI-Fl7Zc69H0hX1WpLpwG9mxUcZf30")
14 b2sums=('09edea9063657373cf6d7d9d8290dddf17b8fb516538d89b83462176127b8b43832bd81f326eec5504116f05ab780023832b8b5d41d72e3ab8e726d89e364a36')
16 build() {
17   make -C $pkgname-$pkgver NASM_OR_YASM=yasm clean 64
20 package() {
21   cd "$pkgname-$pkgver"
22   install -Dm755 e3 "$pkgdir/usr/bin/e3"
23   for f in e3ws e3em e3pi e3vi e3ne; do
24     ln -sf /usr/bin/e3 "$pkgdir/usr/bin/$f"
25   done
26   install -Dm644 e3.man "$pkgdir/usr/share/man/man1/e3.1"