archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / enblend-enfuse / trunk / PKGBUILD
blob389790da8f4878bd436993744146e6bac903dcee
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
2 # Contributor: Daniel Isenmann <daniel@archlinux.org>
3 # Contributor: Dominik Ryba <domryba@post.pl>
5 pkgname=enblend-enfuse
6 pkgver=4.2.r1524+h4c30a326b3f4
7 pkgrel=4
8 pkgdesc="Intelligent blend tool for overlapping picture"
9 arch=(x86_64)
10 url="http://enblend.sourceforge.net"
11 license=(GPL)
12 depends=(lcms2 vigra gsl exiv2)
13 makedepends=(mercurial libjpeg libpng libtiff openexr zlib help2man boost)
14 # The latest revision moves to C++17 instead of boost but requires exiv2 2.28 which is currently unreleased
15 #source=(enblend-enfuse::hg+http://hg.code.sf.net/p/enblend/code#revision=b236375ad1a8
16 source=(enblend-enfuse::hg+http://hg.code.sf.net/p/enblend/code#revision=4c30a326b3f4)
17 sha256sums=(SKIP)
19 pkgver() {
20   cd ${pkgname}
21   printf "4.2.r%s+h%s" "$(hg identify -n)" "$(hg identify -i)"
24 prepare() {
25   cd ${pkgname}
26   make --makefile=Makefile.scm
29 build() {
30   cd ${pkgname}
31   ./configure \
32     --prefix=/usr \
33     --enable-openmp=yes \
34     --enable-opencl=yes \
35     --with-exiv2 \
36     --with-openexr
37   make
40 package() {
41   cd ${pkgname}
42   make DESTDIR="${pkgdir}" install